解決Unsupported major.minor version 51.0錯誤
最近新安裝使用了jdk7,編譯了一些類替換到原來正常運行的項目中,替換之後發生了Unsupported major.minor version 51.0錯誤。經過網上搜索發現了問題產生的原因:用jdk7編譯的class文件放到基於jdk6運行在tomcat之中,就會報這個錯。
解決起來也很方便:打開exclipse中項目上的屬性—java compiler–選擇一個合適的版本後重新編譯即可。

, , ,

狼翔月影 發表在 痞客邦 PIXNET 留言(0) 人氣()